|Description||The ELF loader in Linux kernel 2.4 before 2.4.25 allows local users to cause a denial of service (crash) via a crafted ELF file with an interpreter with an invalid arch (architecture), which triggers a BUG() when an invalid VMA is unmapped.|
|Source||CVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)|
|References||DSA-1067-1, DSA-1069-1, DSA-1070-1, DSA-1082-1|
|NVD severity||medium (attack range: local)|
|Debian/stable||not known to be vulnerable.|
|Debian/testing||not known to be vulnerable.|
|Debian/unstable||not known to be vulnerable.|
Vulnerable and fixed packages
The table below lists information on source packages.
|linux-2.6 (PTS)||squeeze (security), squeeze||2.6.32-48squeeze6||fixed|
The information above is based on the following data on fixed versions.
- linux-2.6 <not-affected> (fixed before first upload)