CVE-2004-0366

NameCVE-2004-0366
DescriptionSQL injection vulnerability in the libpam-pgsql library before 0.5.2 allows attackers to execute arbitrary SQL statements.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-469
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pam-pgsql (PTS)wheezy0.7.3.1-4fixed
sid, jessie, stretch0.7.3.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pam-pgsqlsource(unstable)0.5.2-7.1high
pam-pgsqlsourcewoody0.5.2-3woody2highDSA-469

Notes

fix was accidentially reverted in a later upload and later re-introduced in 0.5.2-9

Search for package or bug name: Reporting problems