CVE-2004-0980

NameCVE-2004-0980
DescriptionFormat string vulnerability in ez-ipupdate.c for ez-ipupdate 3.0.10 through 3.0.11b8, when running in daemon mode with certain service types in use, allows remote servers to execute arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-592-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ez-ipupdate (PTS)wheezy3.0.11b8-13.4fixed
buster, sid, jessie, stretch3.0.11b8-13.4.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ez-ipupdatesource(unstable)3.0.11b8-8high
ez-ipupdatesourcewoody3.0.11b5-1woody2highDSA-592-1

Search for package or bug name: Reporting problems