CVE-2004-1070

NameCVE-2004-1070
DescriptionThe load_elf_binary function in the binfmt_elf loader (binfmt_elf.c) in Linux kernel 2.4.x up to 2.4.27, and 2.6.x up to 2.6.8, does not properly check return values from calls to the kernel_read function, which may allow local users to modify sensitive memory in a setuid program and execute arbitrary code.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1067-1, DSA-1069-1, DSA-1070-1, DSA-1082-1
NVD severityhigh (attack range: local)
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux-2.6 (PTS)squeeze (security), squeeze2.6.32-48squeeze6fixed
squeeze (lts)2.6.32-48squeeze11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kernel-image-sparc-2.4sourcewoody26woody1highDSA-1070-1
kernel-patch-2.4.19-mipssourcewoody2.4.19-0.020911.1.woody5highDSA-1070-1
kernel-source-2.4.16sourcewoody2.4.16-1woody2highDSA-1067-1
kernel-source-2.4.17sourcewoody2.4.17-1woody4highDSA-1082-1
kernel-source-2.4.18sourcewoody2.4.18-14.4highDSA-1069-1
kernel-source-2.4.19sourcewoody2.4.19-4.woody3highDSA-1070-1
kernel-source-2.4.27source(unstable)2.4.27-6high
linux-2.6source(unstable)(not affected)

Notes

- linux-2.6 <not-affected> (Fixed before upload into archive)

Search for package or bug name: Reporting problems