CVE-2004-1179

NameCVE-2004-1179
DescriptionThe debstd script in debmake 3.6.x before 3.6.10 and 3.7.x before 3.7.7 allows local users to overwrite arbitrary files via a symlink attack on temporary directories.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-615-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
debmake (PTS)bullseye4.3.2-1.1fixed
bookworm4.4.0-1fixed
sid, trixie4.4.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
debmakesourcewoody3.6.10.woody.1DSA-615-1
debmakesource(unstable)3.7.7

Search for package or bug name: Reporting problems