CVE-2004-1258

NameCVE-2004-1258
DescriptionBuffer overflow in the put_words function in subs.c for abcm2ps 3.7.20 allows remote attackers to execute arbitrary code via crafted ABC files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
abcm2ps (PTS)stretch7.8.9-1fixed
buster8.14.2-0.2fixed
bookworm, sid, bullseye8.14.11-0.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
abcm2pssource(unstable)4.8.5-1

Search for package or bug name: Reporting problems