CVE-2004-1561

NameCVE-2004-1561
DescriptionBuffer overflow in Icecast 2.0.1 and earlier allows remote attackers to execute arbitrary code via an HTTP request with a large number of headers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icecast2 (PTS)stretch (security), stretch2.4.2-1+deb9u1fixed
buster2.4.4-1fixed
bookworm, sid, bullseye2.4.4-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icecast2source(unstable)2.0.2.debian-1

Search for package or bug name: Reporting problems