CVE-2004-2664

NameCVE-2004-2664
DescriptionJohn Lim ADOdb Library for PHP before 4.23 allows remote attackers to obtain sensitive information via direct requests to certain scripts that result in an undefined value of ADODB_DIR, which reveals the installation path in an error message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libphp-adodb (PTS)stretch5.20.9-1fixed
stretch (security)5.20.9-1+deb9u1fixed
buster, buster (security)5.20.14-1+deb10u1fixed
bullseye (security), bullseye5.20.19-1+deb11u1fixed
bookworm, sid5.21.4-1fixed
phppgadmin (PTS)stretch5.1+ds-2fixed
buster5.1+ds-4fixed
bookworm, sid, bullseye7.13.0+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
egroupwaresource(unstable)(not affected)
gallery2source(unstable)(not affected)
libphp-adodbsource(unstable)(not affected)
moodlesource(unstable)(not affected)
phppgadminsource(unstable)4.0.1-2unimportant
phpwikisource(unstable)(unfixed)unimportant

Search for package or bug name: Reporting problems