CVE-2005-0064

NameCVE-2005-0064
DescriptionBuffer overflow in the Decrypt::makeFileKey2 function in Decrypt.cc for xpdf 3.00 and earlier allows remote attackers to execute arbitrary code via a PDF file with a large /Encrypt /Length keyLength value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-645-1, DSA-648-1
NVD severityhigh
Debian Bugs324459

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups (PTS)stretch2.2.1-8+deb9u6fixed
stretch (security)2.2.1-8+deb9u7fixed
buster2.2.10-6+deb10u4fixed
bullseye2.3.3op2-3+deb11u1fixed
bookworm, sid2.3.3op2-7fixed
xpdf (PTS)stretch3.04-4fixed
buster3.04-13fixed
bullseye3.04+git20210103-3fixed
bookworm, sid3.04+git20211021-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cupssource(unstable)1.1.22-6324459
cupsyssourcewoody1.1.14-5woody12DSA-645-1
cupsyssource(unstable)1.1.22-6324459
gpdfsource(unstable)2.8.2-1.2
kdegraphicssource(unstable)4:3.3.2-2
pdftohtmlsource(unstable)0.36-11
tetex-binsource(unstable)2.0.2-26
xpdfsourcewoody1.00-3.4DSA-648-1
xpdfsource(unstable)3.00-13

Notes

cupsys switched to an xpdf-utils wrapper in version 1.1.22-6.
In version 1.1.23-13, the dormant code in the source
package was fixed.

Search for package or bug name: Reporting problems