CVE-2005-0124

NameCVE-2005-0124
DescriptionThe coda_pioctl function in the coda functionality (pioctl.c) for Linux kernel 2.6.9 and 2.4.x before 2.4.29 may allow local users to cause a denial of service (crash) or execute arbitrary code via negative vi.in_size or vi.out_size values, which may trigger a buffer overflow.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1017-1, DSA-1067-1, DSA-1069-1, DSA-1070-1, DSA-1082-1
NVD severitylow (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot known to be vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux-2.6 (PTS)squeeze, squeeze (security)2.6.32-48squeeze6fixed
squeeze (lts)2.6.32-48squeeze13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kernel-image-sparc-2.4sourcewoody26woody1lowDSA-1070-1
kernel-patch-2.4.19-mipssourcewoody2.4.19-0.020911.1.woody5lowDSA-1070-1
kernel-source-2.4.16sourcewoody2.4.16-1woody2lowDSA-1067-1
kernel-source-2.4.17sourcewoody2.4.17-1woody4lowDSA-1082-1
kernel-source-2.4.18sourcewoody2.4.18-14.4lowDSA-1069-1
kernel-source-2.4.19sourcewoody2.4.19-4.woody3lowDSA-1070-1
kernel-source-2.6.8sourcesarge2.6.8-16sarge2lowDSA-1017-1
linux-2.6source(unstable)2.6.12-1low

Search for package or bug name: Reporting problems