CVE-2005-0372

NameCVE-2005-0372
DescriptionDirectory traversal vulnerability in gftp before 2.0.18 for GTK+ allows remote malicious FTP servers to read arbitrary files via .. (dot dot) sequences in filenames returned from a LIST command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-686-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gftp (PTS)wheezy2.0.19-4fixed
stretch, buster, sid2.0.19-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gftpsource(unstable)2.0.18-1medium
gftpsourcewoody2.0.11-1woody1mediumDSA-686-1

Notes

CVE entry claims that 2.0.18 is vulnerable, but this is wrong.

Search for package or bug name: Reporting problems