CVE-2005-0488

NameCVE-2005-0488
DescriptionCertain BSD-based Telnet clients, including those used on Solaris and SuSE Linux, allow remote malicious Telnet servers to read sensitive environment variables via the NEW-ENVIRON option with a SEND ENV_USERVAR command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)stretch1.15-1+deb9u1fixed
stretch (security)1.15-1+deb9u2fixed
buster1.17-3+deb10u1fixed
buster (security)1.17-3+deb10u2fixed
bullseye1.18.3-6fixed
bookworm, sid1.18.3-7fixed
netkit-telnet (PTS)stretch0.17-41fixed
buster0.17-41.2fixed
bookworm, sid, bullseye0.17-42fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb4source(unstable)(unfixed)unimportant
krb5source(unstable)1.8.3+dfsg-4unimportant
netkit-telnetsource(unstable)(not affected)

Notes

[woody] - krb4 <no-dsa> (Documented behaviour in MIT Kerberos)
[sarge] - krb4 <no-dsa> (Documented behaviour in MIT Kerberos)
[woody] - krb5 <no-dsa> (Documented behaviour in MIT Kerberos)
[sarge] - krb5 <no-dsa> (Documented behaviour in MIT Kerberos)
- netkit-telnet <not-affected> (netkit-telnet is not affected)
telnet code was removed earlier than 1.8.3, but that's the version that was available to check

Search for package or bug name: Reporting problems