CVE-2005-0837

NameCVE-2005-0837
DescriptionIceCast 2.20 allows remote attackers to bypass the XSL parser and obtain the source for XSL files via a request for a .xsl file with a trailing . (dot).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs301368

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icecast2 (PTS)jessie (security), jessie2.4.0-1.1+deb8u1vulnerable
stretch2.4.2-1vulnerable
buster, sid2.4.3-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icecast2source(unstable)(unfixed)unimportant301368

Notes

According to upstream a non-issue

Search for package or bug name: Reporting problems