CVE-2005-1545

NameCVE-2005-1545
DescriptionInteger overflow in the ELF parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted ELF file, which leads to a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-743-1
Debian Bugs308587

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ht (PTS)buster2.1.0+repack1-3fixed
trixie, sid, bookworm, bullseye2.1.0+repack1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
htsourcewoody0.5.0-1woody4DSA-743-1
htsourcesarge0.8.0-2sarge4DSA-743-1
htsource(unstable)0.8.0-3308587

Search for package or bug name: Reporting problems