Information on source package ht

Available versions

ReleaseVersion
jessie2.0.22-2
stretch2.1.0+repack1-2
buster2.1.0+repack1-3
bullseye2.1.0+repack1-3
sid2.1.0+repack1-3

Open issues

BugjessiestretchbusterbullseyesidDescription
TEMP-0773308-EE1012vulnerable (no DSA)fixedfixedfixedfixedcrashes on crafted ELF
CVE-2016-6131vulnerable (no DSA)fixedfixedfixedfixedThe demangler in GNU Libiberty allows remote attackers to cause a deni ...
CVE-2016-4493vulnerable (no DSA)fixedfixedfixedfixedThe demangle_template_value_parm and do_hpacc_template_literal functio ...
CVE-2016-4492vulnerable (no DSA)fixedfixedfixedfixedBuffer overflow in the do_type function in cplus-dem.c in libiberty al ...
CVE-2016-4490vulnerable (no DSA)fixedfixedfixedfixedInteger overflow in cp-demangle.c in libiberty allows remote attackers ...
CVE-2016-4489vulnerable (no DSA)fixedfixedfixedfixedInteger overflow in the gnu_special function in libiberty allows remot ...
CVE-2016-4488vulnerable (no DSA)fixedfixedfixedfixedUse-after-free vulnerability in libiberty allows remote attackers to c ...
CVE-2016-4487vulnerable (no DSA)fixedfixedfixedfixedUse-after-free vulnerability in libiberty allows remote attackers to c ...
CVE-2016-2226vulnerable (no DSA)fixedfixedfixedfixedInteger overflow in the string_appends function in cplus-dem.c in libi ...

Resolved issues

BugDescription
CVE-2005-1546Buffer overflow in the PE parser in HT Editor before 0.8.0 allows remo ...
CVE-2005-1545Integer overflow in the ELF parser in HT Editor before 0.8.0 allows re ...

Security announcements

DSA / DLADescription
DSA-743-1ht - buffer overflows, integer overflows
DSA-743-1ht - buffer overflows, integer overflows

Search for package or bug name: Reporting problems