CVE-2005-1546

NameCVE-2005-1546
DescriptionBuffer overflow in the PE parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted PE file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-743-1
NVD severitymedium (attack range: remote)
Debian Bugs308587

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ht (PTS)wheezy2.0.20-2fixed
jessie2.0.22-2fixed
stretch2.1.0+repack1-2fixed
buster, sid2.1.0+repack1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
htsource(unstable)0.8.0-3medium308587
htsourcesarge0.8.0-2sarge4mediumDSA-743-1
htsourcewoody0.5.0-1woody4mediumDSA-743-1

Search for package or bug name: Reporting problems