CVE-2005-2024

NameCVE-2005-2024
DescriptionVipul Razor Agents (razor-agents) before 2.70 allows remote attackers to cause a denial of service via (1) certain "unusual HTML messages" or (2) "certain malformed headers" such as Content-Type.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-738-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
razor (PTS)squeeze1:2.85-3fixed
wheezy1:2.85-4fixed
sid, jessie1:2.85-4.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
razorsource(unstable)2.720-1low
razorsourcesarge2.670-1sarge2lowDSA-738-1
razorsourcewoody(not affected)DSA-738-1

Notes

varying and apparently innacurate info about what versions fix it

Search for package or bug name: Reporting problems