CVE-2005-2336

NameCVE-2005-2336
DescriptionCross-site scripting (XSS) vulnerability in Hiki 0.8.0 to 0.8.2 allows remote attackers to inject arbitrary web script or HTML via "missing pages" in which the page name is not properly escaped, a different vulnerability than CVE-2005-2803.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hiki (PTS)buster, stretch1.0.0-2fixed
bookworm, sid, bullseye1.0.0-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hikisourcesarge(not affected)
hikisource(unstable)0.8.2-1

Notes

[sarge] - hiki <not-affected> (code not present in sarge)

Search for package or bug name: Reporting problems