CVE-2005-2337

NameCVE-2005-2337
DescriptionRuby 1.6.x up to 1.6.8, 1.8.x up to 1.8.2, and 1.9.0 development up to 2005-09-01 allows attackers to bypass safe level and taint flag protections and execute disallowed code when Ruby processes a program through standard input (stdin).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-860-1, DSA-862-1, DSA-864-1
NVD severityhigh (attack range: remote)
Debian Bugs332742

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby1.8 (PTS)wheezy1.8.7.358-7.1+deb7u3fixed
wheezy (security)1.8.7.358-7.1+deb7u4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rubysource(unstable)(unfixed)high
rubysourcewoody1.6.7-3woody5highDSA-860-1
ruby1.6source(unstable)1.6.8-13medium
ruby1.6sourcesarge1.6.8-12sarge1highDSA-862-1
ruby1.8source(unstable)1.8.3-1medium332742
ruby1.8sourcesarge1.8.2-7sarge2highDSA-864-1
ruby1.9source(unstable)1.9.0+20050921-1medium

Search for package or bug name: Reporting problems