CVE-2005-2536

NameCVE-2005-2536
Descriptionpstotext before 1.8g does not properly use the "-dSAFER" option when calling Ghostscript to extract plain text from PostScript and PDF files, which allows remote attackers to execute arbitrary commands via a malicious PostScript file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-792-1
NVD severityhigh (attack range: remote)
Debian Bugs319758

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pstotext (PTS)wheezy, buster, sid, jessie, stretch1.9-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pstotextsource(unstable)1.9-2medium319758
pstotextsourcesarge1.9-1sarge1mediumDSA-792-1
pstotextsourcewoody1.8g-5woody1mediumDSA-792-1

Search for package or bug name: Reporting problems