CVE-2005-2929

NameCVE-2005-2929
DescriptionLynx 2.8.5, and other versions before 2.8.6dev.15, allows remote attackers to execute arbitrary commands via (1) lynxcgi:, (2) lynxexec, and (3) lynxprog links, which are not properly restricted in the default configuration in some environments.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lynx (PTS)stretch2.8.9dev11-1fixed
stretch (security)2.8.9dev11-1+deb9u1fixed
buster, buster (security)2.8.9rel.1-3+deb10u1fixed
bullseye (security), bullseye2.9.0dev.6-3~deb11u1fixed
bookworm, sid2.9.0dev.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lynxsource(unstable)(not affected)

Notes

- lynx <not-affected> (Debian's default config is not vulnerable)

Search for package or bug name: Reporting problems