CVE-2005-2964

NameCVE-2005-2964
DescriptionStack-based buffer overflow in AbiWord before 2.2.10 allows attackers to execute arbitrary code via the RTF import mechanism.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-894-1
NVD severityhigh (attack range: remote)
Debian Bugs329839

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
abiword (PTS)wheezy2.9.2+svn20120603-8fixed
jessie3.0.0-8fixed
stretch3.0.2-2fixed
buster, sid3.0.2-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
abiwordsource(unstable)2.2.10-1medium329839
abiwordsourcesarge2.2.7-3sarge2highDSA-894-1
abiwordsourcewoody1.0.2+cvs.2002.06.05-1woody3highDSA-894-1

Search for package or bug name: Reporting problems