CVE-2005-3540

NameCVE-2005-3540
DescriptionBuffer overflow in petris before 1.0.1 allows remote attackers to execute arbitrary code via unspecified attack vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-929-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
petris (PTS)wheezy, jessie1.0.1-8fixed
stretch, buster, sid1.0.1-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
petrissource(unstable)1.0.1-5high
petrissourcesarge1.0.1-4sarge0highDSA-929-1

Search for package or bug name: Reporting problems