CVE-2005-3656

NameCVE-2005-3656
DescriptionMultiple format string vulnerabilities in logging functions in mod_auth_pgsql before 2.0.3, when used for user authentication against a PostgreSQL database, allows remote unauthenticated attackers to execute arbitrary code, as demonstrated via the username.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-935-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libapache2-mod-auth-pgsql (PTS)wheezy2.0.3-5fixed
buster, sid, jessie, stretch2.0.3-6.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libapache-mod-auth-pgsqlsource(unstable)(not affected)
libapache2-mod-auth-pgsqlsource(unstable)2.0.2b1-7high
libapache2-mod-auth-pgsqlsourcesarge2.0.2b1-5sarge0high

Notes

- libapache-mod-auth-pgsql <not-affected> (Does not contain the vulnerable ap_log_rerror() function)

Search for package or bug name: Reporting problems