CVE-2006-1010

NameCVE-2006-1010
DescriptionBuffer overflow in socket/request.c in CrossFire before 1.9.0, when oldsocketmode is enabled, allows remote attackers to cause a denial of service (segmentation fault) and possibly execute code by sending the server a large request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1001-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
crossfire (PTS)wheezy1.70.0-1fixed
buster, sid, jessie, stretch1.71.0+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
crossfiresource(unstable)1.9.0-1medium
crossfiresourcesarge1.6.0.dfsg.1-4sarge1mediumDSA-1001-1
crossfiresourcewoody1.1.0-1woody1mediumDSA-1001-1

Search for package or bug name: Reporting problems