CVE-2006-1236

NameCVE-2006-1236
DescriptionBuffer overflow in the SetUp function in socket/request.c in CrossFire 1.9.0 allows remote attackers to execute arbitrary code via a long setup sound command, a different vulnerability than CVE-2006-1010.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1009-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
crossfire (PTS)wheezy1.70.0-1fixed
buster, sid, jessie, stretch1.71.0+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
crossfiresource(unstable)1.9.0-2medium
crossfiresourcesarge1.6.0.dfsg.1-4sarge2highDSA-1009-1
crossfiresourcewoody1.1.0-1woody2highDSA-1009-1

Search for package or bug name: Reporting problems