CVE-2006-1515

NameCVE-2006-1515
DescriptionBuffer overflow in the addnewword function in typespeed 0.4.4 and earlier might allow remote attackers to execute arbitrary code via unknown vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1084-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
typespeed (PTS)wheezy0.6.5-1.1fixed
buster, sid, jessie, stretch0.6.5-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
typespeedsource(unstable)0.4.4-10high
typespeedsourcesarge0.4.4-8sarge1highDSA-1084-1
typespeedsourcewoody0.4.1-2.4highDSA-1084-1

Search for package or bug name: Reporting problems