CVE-2006-1727

NameCVE-2006-1727
DescriptionUnspecified vulnerability in Mozilla Firefox and Thunderbird 1.x before 1.5.0.2 and 1.0.x before 1.0.8, Mozilla Suite before 1.7.13, and SeaMonkey before 1.0.1 allows remote attackers to gain chrome privileges via multiple attack vectors related to the use of XBL scripts with "Print Preview".
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-1044-1, DSA-1046-1, DSA-1051-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid107.0-1fixed
thunderbird (PTS)buster1:91.12.0-1~deb10u1fixed
buster (security)1:102.5.0-1~deb10u1fixed
bullseye1:91.13.0-1~deb11u1fixed
bullseye (security)1:102.5.0-1~deb11u1fixed
bookworm, sid1:102.5.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)1.5.dfsg+1.5.0.2-1medium
mozillasourcesarge2:1.7.8-1sarge5DSA-1046-1
mozillasource(unstable)2:1.7.13-0.1medium
mozilla-firefoxsourcesarge1.0.4-2sarge6DSA-1044-1
mozilla-firefoxsource(unstable)1.5.dfsg+1.5.0.2-1medium
mozilla-thunderbirdsourcesarge1.0.2-2.sarge1.0.8medium
thunderbirdsource(unstable)1.5.0.2-1medium
xulrunnersource(unstable)1.8.0.1-9

Notes

If print preview (and this bug) can be triggered from JavaScript,
the urgency should probably be raised.

Search for package or bug name: Reporting problems