CVE-2006-2194

NameCVE-2006-2194
DescriptionThe winbind plugin in pppd for ppp 2.4.4 and earlier does not check the return code from the setuid function call, which might allow local users to gain privileges by causing setuid to fail, such as exceeding PAM limits for the maximum number of user processes, which prevents the winbind NTLM authentication helper from dropping privileges.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1106
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ppp (PTS)wheezy, wheezy (security)2.4.5-5.1+deb7u2fixed
jessie2.4.6-3.1fixed
buster, sid, stretch2.4.7-1+4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pppsource(unstable)2.4.4rel-1medium
pppsourcesarge2.4.3-20050321+2sarge1highDSA-1106

Search for package or bug name: Reporting problems