CVE-2006-2230

NameCVE-2006-2230
DescriptionMultiple format string vulnerabilities in xiTK (xitk/main.c) in xine 0.99.4 might allow attackers to cause a denial of service via format string specifiers in an MP3 filename specified on the command line. NOTE: this is a different vulnerability than CVE-2006-1905. In addition, if the only attack vectors involve a user-assisted, local command line argument of a non-setuid program, this issue might not be a vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1093-1
NVD severitymedium (attack range: remote)
Debian Bugs363370, 372172

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xine-ui (PTS)wheezy0.99.7-1fixed
jessie0.99.9-1.2fixed
buster, sid, stretch0.99.9-1.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xine-uisource(unstable)0.99.4-2medium363370, 372172
xine-uisourcesarge0.99.3-1sarge1mediumDSA-1093-1

Search for package or bug name: Reporting problems