CVE-2006-2769

NameCVE-2006-2769
DescriptionThe HTTP Inspect preprocessor (http_inspect) in Snort 2.4.0 through 2.4.4 allows remote attackers to bypass "uricontent" rules via a carriage return (\r) after the URL and before the HTTP declaration.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs381726

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
snort (PTS)bullseye (security)2.9.20-0+deb11u1fixed
sid2.9.15.1-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
snortsource(unstable)2.3.3-8low381726

Notes

[sarge] - snort <no-dsa> (Minor impact)

Search for package or bug name: Reporting problems