CVE-2006-2784

NameCVE-2006-2784
DescriptionThe PLUGINSPAGE functionality in Mozilla Firefox before 1.5.0.4 allows remote user-assisted attackers to execute privileged code by tricking a user into installing missing plugins and selecting the "Manual Install" button, then using nested javascript: URLs. NOTE: the manual install button is used for downloading software from a remote web site, so this issue would not cross privilege boundaries if the user progresses to the point of installing malicious software from the attacker-controlled site.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1118, DSA-1120, DSA-1134-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablenot known to be vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xulrunner (PTS)wheezy (security), wheezy24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)1.5.dfsg+1.5.0.4-1medium
mozillasource(unstable)(unfixed)medium
mozillasourcesarge2:1.7.8-1sarge7.1mediumDSA-1118
mozilla-firefoxsourcesarge1.0.4-2sarge9mediumDSA-1120
mozilla-thunderbirdsourcesarge1.0.2-2.sarge1.0.8amediumDSA-1134-1
xulrunnersource(unstable)1.8.0.4-1medium

Notes

MFSA-2006-36

Search for package or bug name: Reporting problems