CVE-2006-3810

NameCVE-2006-3810
DescriptionCross-site scripting (XSS) vulnerability in Mozilla Firefox 1.5 before 1.5.0.5, Thunderbird before 1.5.0.5, and SeaMonkey before 1.0.3 allows remote attackers to inject arbitrary web script or HTML via the XPCNativeWrapper(window).Function construct.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1159
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot known to be vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xulrunner (PTS)wheezy (security), wheezy24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)1.5.dfsg+1.5.0.5-1high
mozillasource(unstable)(not affected)
mozilla-firefoxsource(unstable)(not affected)
mozilla-thunderbirdsourcesarge1.0.2-2.sarge1.0.8b.1mediumDSA-1159
thunderbirdsource(unstable)1.5.0.5-1medium
xulrunnersource(unstable)1.8.0.5-1high

Notes

MFSA-2006-54
- mozilla <not-affected> (mozilla 1.7 not affected)
- mozilla-firefox <not-affected> (only firefox >= 1.5)

Search for package or bug name: Reporting problems