CVE-2006-4573

NameCVE-2006-4573
DescriptionMultiple unspecified vulnerabilities in the "utf8 combining characters handling" (utf8_handle_comb function in encoding.c) in screen before 4.0.3 allows user-assisted attackers to cause a denial of service (crash or hang) via certain UTF8 sequences.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1202-1
NVD severitylow (attack range: remote, user-initiated)
Debian Bugs395225, 395999
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
screen (PTS)squeeze4.0.3-14fixed
wheezy4.1.0~20120320gitdb59704-7fixed
stretch, sid, jessie4.2.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
screensource(unstable)4.0.3-0.1medium395225, 395999
screensourcesarge4.0.2-4.1sarge1lowDSA-1202-1

Search for package or bug name: Reporting problems