DescriptionMultiple unspecified vulnerabilities in the "utf8 combining characters handling" (utf8_handle_comb function in encoding.c) in screen before 4.0.3 allows user-assisted attackers to cause a denial of service (crash or hang) via certain UTF8 sequences.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, web search, more)
NVD severitylow (attack range: remote)
Debian Bugs395225, 395999
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
screen (PTS)squeeze4.0.3-14fixed
squeeze (lts)4.0.3-14+deb6u1fixed
wheezy (security)4.1.0~20120320gitdb59704-7+deb7u1fixed
jessie (security), jessie4.2.1-3+deb8u1fixed
stretch, sid4.3.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
screensource(unstable)4.0.3-0.1medium395225, 395999

Search for package or bug name: Reporting problems