Information on source package screen

Available versions

ReleaseVersion
stretch4.5.0-6
stretch (security)4.5.0-6+deb9u1
buster4.6.2-3+deb10u1
bullseye4.8.0-6
bookworm4.8.0-7
sid4.8.0-7

Resolved issues

BugDescription
CVE-2021-26937encoding.c in GNU Screen through 4.8.0 allows remote attackers to caus ...
CVE-2020-9366A buffer overflow was found in the way GNU Screen before 4.8.0 treated ...
CVE-2017-5618GNU screen before 4.5.1 allows local users to modify arbitrary files a ...
CVE-2015-6806The MScrollV function in ansi.c in GNU screen 4.3.1 and earlier does n ...
CVE-2009-1215Race condition in GNU screen 4.0.3 allows local users to create or ove ...
CVE-2009-1214GNU screen 4.0.3 creates the /tmp/screen-exchange temporary file with ...
CVE-2007-3048
CVE-2006-4573Multiple unspecified vulnerabilities in the "utf8 combining characters ...
CVE-2003-0972Integer signedness error in ansi.c for GNU screen 4.0.1 and earlier, a ...
CVE-2002-1602Buffer overflow in the Braille module for GNU screen 3.9.11, when HAVE ...

Security announcements

DSA / DLADescription
DSA-4861-1screen - security update
DLA-2570-1screen - security update
DLA-305-1screen - security update
DSA-3352-1screen - security update
DSA-1202-1screen - programming error
DSA-408screen - integer overflow

Search for package or bug name: Reporting problems