CVE-2006-4618

NameCVE-2006-4618
DescriptionPHP remote file inclusion vulnerability in adodb-postgres7.inc.php in John Lim ADOdb, possibly 4.01 and earlier, as used in Intechnic In-link 2.3.4, allows remote attackers to execute arbitrary PHP code via a URL in the ADODB_DIR parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libphp-adodb (PTS)stretch5.20.9-1fixed
stretch (security)5.20.9-1+deb9u1fixed
buster, buster (security)5.20.14-1+deb10u1fixed
bullseye (security), bullseye5.20.19-1+deb11u1fixed
bookworm, sid5.21.4-1fixed
phppgadmin (PTS)stretch5.1+ds-2fixed
buster5.1+ds-4fixed
bookworm, sid, bullseye7.13.0+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
egroupwaresource(unstable)(not affected)
gallery2source(unstable)(not affected)
libphp-adodbsource(unstable)(not affected)
moodlesource(unstable)(not affected)
phppgadminsource(unstable)(not affected)
phpwikisource(unstable)(not affected)

Notes

- libphp-adodb <not-affected> (vulnerable code seems to be In-link specific)
- egroupware <not-affected> (vulnerable code seems to be In-link specific)
- moodle <not-affected> (vulnerable code seems to be In-link specific)
- phppgadmin <not-affected> (vulnerable code seems to be In-link specific)
- gallery2 <not-affected> (vulnerable code seems to be In-link specific)
- phpwiki <not-affected> (vulnerable code seems to be In-link specific)

Search for package or bug name: Reporting problems