CVE-2006-5467

NameCVE-2006-5467
DescriptionThe cgi.rb CGI library for Ruby 1.8 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via an HTTP request with a multipart MIME body that contains an invalid boundary specifier, as demonstrated using a specifier that begins with a "-" instead of "--" and contains an inconsistent ID.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1234-1, DSA-1235-1
NVD severitymedium (attack range: remote)
Debian Bugs398457

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby1.8 (PTS)wheezy1.8.7.358-7.1+deb7u3fixed
wheezy (security)1.8.7.358-7.1+deb7u4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby1.6sourcesarge1.6.8-12sarge3mediumDSA-1234-1
ruby1.8source(unstable)1.8.5-3low398457
ruby1.8sourcesarge1.8.2-7sarge5mediumDSA-1235-1
ruby1.9source(unstable)1.9.0+20070606-1low

Notes

[etch] - ruby1.9 <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems