CVE-2006-6503

NameCVE-2006-6503
DescriptionMozilla Firefox 2.x before 2.0.0.1, 1.5.x before 1.5.0.9, Thunderbird before 1.5.0.9, and SeaMonkey before 1.0.7 allows remote attackers to bypass cross-site scripting (XSS) protection by changing the src attribute of an IMG element to a javascript: URI.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1253-1, DSA-1258-1, DSA-1265-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid48.0-1fixed
firefox-esr (PTS)wheezy (security)45.3.0esr-1~deb7u1fixed
jessie (security)45.3.0esr-1~deb8u1fixed
stretch, sid45.3.0esr-1fixed
icedove (PTS)wheezy38.7.0-1~deb7u1fixed
wheezy (security)1:45.2.0-2~deb7u1fixed
jessie38.8.0-1~deb8u1fixed
jessie (security)1:45.2.0-1~deb8u1fixed
stretch, sid1:45.2.0-4fixed
iceweasel (PTS)wheezy (security), wheezy38.8.0esr-1~deb7u1fixed
jessie (security), jessie38.8.0esr-1~deb8u1fixed
xulrunner (PTS)wheezy (security), wheezy24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)45.0-1high
firefox-esrsource(unstable)45.0esr-1high
iceapesource(unstable)1.0.7-1high
icedovesource(unstable)1.5.0.9.dfsg1-1high
iceweaselsource(unstable)2.0.0.1+dfsg-1high
mozillasource(unstable)(unfixed)high
mozillasourcesarge2:1.7.8-1sarge10mediumDSA-1265-1
mozilla-firefoxsource(unstable)(unfixed)high
mozilla-firefoxsourcesarge1.0.4-2sarge15mediumDSA-1253-1
mozilla-thunderbirdsource(unstable)(unfixed)high
mozilla-thunderbirdsourcesarge1.0.2-2.sarge1.0.8e.2mediumDSA-1258-1
xulrunnersource(unstable)1.8.0.9-1high

Notes

MFSA-2006-72

Search for package or bug name: Reporting problems