CVE-2006-7225

NameCVE-2006-7225
DescriptionPerl-Compatible Regular Expression (PCRE) library before 6.7 allows context-dependent attackers to cause a denial of service (error or crash) via a regular expression that involves a "malformed POSIX character class", as demonstrated via an invalid character after a [[ sequence.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glib2.0 (PTS)buster2.58.3-2+deb10u3fixed
buster (security)2.58.3-2+deb10u6fixed
bullseye2.66.8-1+deb11u1fixed
bullseye (security)2.66.8-1+deb11u3fixed
bookworm2.74.6-2fixed
bookworm (security)2.74.6-2+deb12u2fixed
trixie2.80.2-2fixed
sid2.80.3-1fixed
pcre3 (PTS)buster2:8.39-12fixed
bullseye2:8.39-13fixed
sid, trixie, bookworm2:8.39-15fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glib2.0source(unstable)2.14.3-1unimportant
pcre3sourcesarge4.5+7.4-1
pcre3sourceetch6.7+7.4-2
pcre3source(unstable)6.7-1

Notes

glib only embeds pcre in the udeb, no attack vector

Search for package or bug name: Reporting problems