Information on source package glib2.0

Available versions

ReleaseVersion
jessie2.42.1-1
stretch2.50.3-2
buster2.58.1-2
sid2.58.1-2

Open issues

BugjessiestretchbustersidDescription
CVE-2018-16429vulnerable (no DSA)vulnerable (no DSA)fixedfixedGNOME GLib 2.56.1 has an out-of-bounds read vulnerability in ...
CVE-2018-16428vulnerable (no DSA)vulnerable (no DSA)fixedfixedIn GNOME GLib 2.56.1, g_markup_parse_context_end_parse() in gmarkup.c ...

Open unimportant issues

BugjessiestretchbustersidDescription
CVE-2012-0039vulnerablevulnerablevulnerablevulnerable** DISPUTED ** GLib 2.31.8 and earlier, when the g_str_hash function ...

Resolved issues

BugDescription
CVE-2012-3524libdbus 1.5.x and earlier, when used in setuid or other privileged ...
CVE-2009-3289The g_file_copy function in glib 2.0 sets the permissions of a target ...
CVE-2008-4316Multiple integer overflows in glib/gbase64.c in GLib before 2.20 allow ...
CVE-2007-4768Heap-based buffer overflow in Perl-Compatible Regular Expression ...
CVE-2007-4767Perl-Compatible Regular Expression (PCRE) library before 7.3 does not ...
CVE-2007-4766Multiple integer overflows in Perl-Compatible Regular Expression ...
CVE-2007-1662Perl-Compatible Regular Expression (PCRE) library before 7.3 reads ...
CVE-2007-1661Perl-Compatible Regular Expression (PCRE) library before 7.3 ...
CVE-2007-1660Perl-Compatible Regular Expression (PCRE) library before 7.0 does not ...
CVE-2007-1659Perl-Compatible Regular Expression (PCRE) library before 7.3 allows ...
CVE-2006-7226Perl-Compatible Regular Expression (PCRE) library before 6.7 does not ...
CVE-2006-7225Perl-Compatible Regular Expression (PCRE) library before 6.7 allows ...

Security announcements

DSA / DLADescription
DSA-1747-1glib2.0 - arbitrary code execution
DSA-1747-1glib2.0 - arbitrary code execution

Search for package or bug name: Reporting problems