CVE-2006-7226

NameCVE-2006-7226
DescriptionPerl-Compatible Regular Expression (PCRE) library before 6.7 does not properly calculate the compiled memory allocation for regular expressions that involve a quantified "subpattern containing a named recursion or subroutine reference," which allows context-dependent attackers to cause a denial of service (error or crash).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glib2.0 (PTS)jessie2.42.1-1fixed
stretch2.50.3-2fixed
buster, sid2.58.1-2fixed
pcre3 (PTS)jessie2:8.35-3.3+deb8u4fixed
stretch2:8.39-3fixed
buster, sid2:8.39-11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glib2.0source(unstable)2.14.3-1unimportant
pcre3source(unstable)6.7-1medium
pcre3sourceetch6.7+7.4-2medium
pcre3sourcesarge4.5+7.4-1medium

Notes

glib only embeds pcre in the udeb, no attack vector

Search for package or bug name: Reporting problems