CVE-2007-1116

NameCVE-2007-1116
DescriptionThe CheckLoadURI function in Mozilla Firefox 1.8 lists the about: URI as a ChromeProtocol and can be loaded via JavaScript, which allows remote attackers to obtain sensitive information by querying the browser's session history.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1300-1, DSA-1306-1, DSA-1308-1, DTSA-45-1, DTSA-47-1, DTSA-51-1
NVD severitymedium
Debian Bugs415919, 415944, 415945

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesourceetch1.0.9-0etch1DSA-1300-1
iceapesourcelenny1.0.10~pre070720-0etch1+lenny1DTSA-47-1
iceapesource(unstable)1.1.2-1low
iceweaselsourceetch2.0.0.4-0etch1DSA-1308-1
iceweaselsourcelenny2.0.0.5-0etch1+lenny1DTSA-45-1
iceweaselsource(unstable)2.0.0.4-1low
xulrunnersourceetch1.8.0.12-0etch1DSA-1306-1
xulrunnersourcelenny1.8.0.13~pre070720-0etch3+lenny1DTSA-51-1
xulrunnersource(unstable)1.8.1.4-1low415919, 415944, 415945

Notes

according to a blog comment at http://www.gnucitizen.org/projects/hscan-redux/,
older mozillas are not vulnerable

Search for package or bug name: Reporting problems