CVE-2007-1267

NameCVE-2007-1267
DescriptionSylpheed 2.2.7 and earlier does not properly use the --status-fd argument when invoking GnuPG, which prevents Sylpheed from visually distinguishing between signed and unsigned portions of OpenPGP messages with multiple components, which allows remote attackers to forge the contents of a message without detection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sylpheed (PTS)wheezy3.2.0-1vulnerable
jessie3.5.0~beta1~r3426-1vulnerable
stretch3.5.1-2vulnerable
buster, sid3.6.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sylpheedsource(unstable)(unfixed)unimportant

Notes

this is a "feature request", since gnupg is fixed from CVE-2007-1263

Search for package or bug name: Reporting problems