CVE-2007-1558

NameCVE-2007-1558
DescriptionThe APOP protocol allows remote attackers to guess the first 3 characters of a password via man-in-the-middle (MITM) attacks that use crafted message IDs and MD5 collisions. NOTE: this design-level issue potentially affects all products that use APOP, including (1) Thunderbird 1.x before 1.5.0.12 and 2.x before 2.0.0.4, (2) Evolution, (3) mutt, (4) fetchmail before 6.3.8, (5) SeaMonkey 1.0.x before 1.0.9 and 1.1.x before 1.1.2, (6) Balsa 2.3.16 and earlier, (7) Mailfilter before 0.8.2, and possibly other products.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1300-1, DSA-1305-1, DTSA-46-1, DTSA-47-1
NVD severitylow (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
balsa (PTS)squeeze2.4.1-1fixed
jessie, sid, wheezy2.4.12-1fixed
claws-mail (PTS)squeeze3.7.6-4+squeeze1fixed
wheezy3.8.1-2fixed
jessie, sid3.11.1-3fixed
fetchmail (PTS)squeeze6.3.18-2fixed
wheezy6.3.21-4fixed
jessie, sid6.3.26-1fixed
iceape (PTS)squeeze (security)2.0.11-17fixed
icedove (PTS)squeeze (security), squeeze3.0.11-1+squeeze15fixed
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.5.0-1~deb7u1fixed
jessie, sid31.5.0-1fixed
mailfilter (PTS)squeeze0.8.2-1fixed
wheezy0.8.2-4fixed
jessie, sid0.8.3-1fixed
mutt (PTS)squeeze (security), squeeze1.5.20-9+squeeze3fixed
squeeze (lts)1.5.20-9+squeeze4fixed
wheezy, wheezy (security)1.5.21-6.2+deb7u3fixed
jessie, sid1.5.23-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
balsasource(unstable)2.3.17-1unimportant
claws-mailsource(unstable)2.9.1-1unimportant
fetchmailsource(unstable)6.3.8-1unimportant
fetchmailsourceetch6.3.6-1etch3low
iceapesource(unstable)1.1.2-1low
iceapesourceetch1.0.9-0etch1lowDSA-1300-1
iceapesourcelenny1.0.10~pre070720-0etch1+lenny1lowDTSA-47-1
icedovesource(unstable)2.0.0.4-1low
icedovesourceetch1.5.0.12.dfsg1-0etch1lowDSA-1305-1
icedovesourcelenny1.5.0.12.dfsg1-0etch1+lenny1lowDTSA-46-1
mailfiltersource(unstable)0.8.2-1unimportant
muttsource(unstable)1.5.18-6unimportant

Notes

Affects various clients, but no practical security implications
MFSA2007-15
i couldn't pinpoint exact mutt fixed version, but lenny's version has the
patch and etch's version does not (http://dev.mutt.org/trac/ticket/2846)

Search for package or bug name: Reporting problems