CVE-2007-2022

NameCVE-2007-2022
DescriptionAdobe Macromedia Flash Player 7 and 9, when used with Opera before 9.20 or Konqueror before 20070613, allows remote attackers to obtain sensitive information (browser keystrokes), which are leaked to the Flash Player applet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
flashplugin-nonfree (PTS)wheezy/contrib1:3.2+wheezy1fixed
jessie/contrib1:3.6.1+deb8u1fixed
sid/contrib1:3.7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
flashplugin-nonfreesource(unstable)9.0.48.0.1medium

Notes

[sarge] - flashplugin-nonfree <no-dsa> (Non-free not supported)
[etch] - flashplugin-nonfree <no-dsa> (Non-free not supported)
Flash Plugin has a vulnerablity, which will only be disclosed in a few months
Some browser vendors produce updates, which fix this issue on the browser side,
but that it not of concern for Debian

Search for package or bug name: Reporting problems