CVE-2007-2292

NameCVE-2007-2292
DescriptionCRLF injection vulnerability in the Digest Authentication support for Mozilla Firefox before 2.0.0.8 and SeaMonkey before 1.1.5 allows remote attackers to conduct HTTP request splitting attacks via LF (%0a) bytes in the username attribute.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1392-1, DSA-1396-1, DSA-1401-1, DTSA-69-1, DTSA-80-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
iceweasel (PTS)squeeze, squeeze (security)3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.8.0esr-1~deb7u1fixed
jessie31.6.0esr-1fixed
jessie (security)31.8.0esr-1~deb8u1fixed
stretch, sid38.1.0esr-3fixed
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)1.1.5medium
iceapesourceetch1.0.11~pre071022-0etch1mediumDSA-1401-1
iceapesourcelenny1.0.11~pre071022-0etch1+lenny1mediumDTSA-80-1
iceweaselsource(unstable)2.0.0.8-1low
iceweaselsourceetch2.0.0.6+2.0.0.8-0etch1mediumDSA-1396-1
xulrunnersource(unstable)1.8.1.9-1medium
xulrunnersourceetch1.8.0.14~pre071019b-0etch1mediumDSA-1392-1
xulrunnersourcelenny1.8.0.14~pre071019b-0lenny1mediumDTSA-69-1

Search for package or bug name: Reporting problems