CVE-2007-2692

NameCVE-2007-2692
DescriptionThe mysql_change_db function in MySQL 5.0.x before 5.0.40 and 5.1.x before 5.1.18 does not restore THD::db_access privileges when returning from SQL SECURITY INVOKER stored routines, which allows remote authenticated users to gain privileges.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1413-1
NVD severitymedium (attack range: remote)
Debian Bugs424778
Debian/oldstablenot known to be vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mysql-dfsgsourcesarge4.0.24-10sarge3mediumDSA-1413-1
mysql-dfsg-4.1sourcesarge4.1.11a-4sarge8mediumDSA-1413-1
mysql-dfsg-5.0source(unstable)5.0.42medium424778
mysql-dfsg-5.0sourceetch5.0.32-7etch3mediumDSA-1413-1

Notes

[sarge] - mysql-dfsg-4.1 <not-affected> (Vulnerable functionality not implemented)
[sarge] - mysql-dfsg <not-affected> (Vulnerable functionality not implemented)
http://bugs.mysql.com/bug.php?id=28499

Search for package or bug name: Reporting problems