CVE-2007-2836

NameCVE-2007-2836
DescriptionDirectory traversal vulnerability in session.rb in Hiki 0.8.0 through 0.8.6 allows remote attackers to delete arbitrary files via directory traversal sequences in the session ID, which is matched against an insufficiently restrictive regular expression before it is used to construct a filename that is marked for deletion at logout.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1324-1
NVD severitymedium (attack range: remote)
Debian Bugs430691
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hiki (PTS)squeeze0.8.8.1-1fixed
wheezy0.8.8.1-3fixed
jessie1.0.0-0.2fixed
stretch, sid1.0.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hikisource(unstable)0.8.7-1medium430691
hikisourceetch0.8.6-1etch1mediumDSA-1324-1
hikisourcesarge(not affected)

Notes

[sarge] - hiki <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems