CVE-2007-2870

NameCVE-2007-2870
DescriptionMozilla Firefox 1.5.x before 1.5.0.12 and 2.x before 2.0.0.4, and SeaMonkey 1.0.9 and 1.1.2, allows remote attackers to bypass the same-origin policy and conduct cross-site scripting (XSS) and other attacks by using the addEventListener method to add an event listener for a site, which is executed in the context of that site.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1300-1, DSA-1306-1, DSA-1308-1, DTSA-45-1, DTSA-47-1, DTSA-51-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
iceweasel (PTS)squeeze (security), squeeze3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.6.0esr-1~deb7u1fixed
jessie, sid31.6.0esr-1fixed
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)1.1.2-1medium
iceapesourceetch1.0.9-0etch1mediumDSA-1300-1
iceapesourcelenny1.0.10~pre070720-0etch1+lenny1mediumDTSA-47-1
iceweaselsource(unstable)2.0.0.4-1medium
iceweaselsourceetch2.0.0.4-0etch1mediumDSA-1308-1
iceweaselsourcelenny2.0.0.5-0etch1+lenny1mediumDTSA-45-1
xulrunnersource(unstable)1.8.1.4-1medium
xulrunnersourceetch1.8.0.12-0etch1mediumDSA-1306-1
xulrunnersourcelenny1.8.0.13~pre070720-0etch3+lenny1mediumDTSA-51-1

Notes

MFSA2007-16
[sarge] - mozilla <no-dsa> (Mozilla products from Sarge no longer supported)

Search for package or bug name: Reporting problems