CVE-2007-3106

NameCVE-2007-3106
Descriptionlib/info.c in libvorbis 1.1.2, and possibly other versions before 1.2.0, allows context-dependent attackers to cause a denial of service and possibly execute arbitrary code via invalid (1) blocksize_0 and (2) blocksize_1 values, which trigger a "heap overwrite" in the _01inverse function in res0.c. NOTE: this issue has been RECAST so that CVE-2007-4029 handles additional vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1471-1
NVD severitymedium (attack range: remote)
Debian Bugs669196
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvorbis (PTS)squeeze, squeeze (security)1.3.1-1+squeeze1fixed
wheezy1.3.2-1.3fixed
stretch, sid, jessie1.3.4-2fixed
libvorbisidec (PTS)squeeze1.0.2+svn16259-2fixed
stretch, sid, jessie, wheezy1.0.2+svn18153-0.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvorbissource(unstable)1.2.0.dfsg-1medium
libvorbissourceetch1.1.2.dfsg-1.3mediumDSA-1471-1
libvorbissourcesarge1.1.0-2mediumDSA-1471-1
libvorbisidecsource(unstable)1.0.2+svn16259-2medium669196

Search for package or bug name: Reporting problems